What I found for us... - Page 2 - Scion XB Forum
User Tag List

Reply
 
LinkBack Thread Tools
post #11 of 16 (permalink) Old 07-14-2014, 03:00 AM
Senior Member
 
5zero4's Avatar
 
Join Date: Nov 2012
Posts: 840
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
5zero4 is offline  
Sponsored Links
Advertisement
 
post #12 of 16 (permalink) Old 07-27-2014, 07:47 PM
Senior Member
 
zinger's Avatar
 
Join Date: Aug 2010
Location: NW Indiana
Posts: 963
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Default KSport Lowering Springs $100

08-12 scion xb lowering springs

RS 6 WeatherTech digital-fit mats Fog lights WeatherTech in-channel visors TRD rear sway bar 5000K HID's Oznium 3rd brake light
zinger is offline  
post #13 of 16 (permalink) Old 07-27-2014, 09:03 PM
Member
 
Join Date: Dec 2012
Posts: 97
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

A little warning about K-Sport lowering springs. When installed your Xb will have a slight reverse rake. Meaning, the front will be higher than the rear. If you trim one coil loop from each of the front springs it will even the car out.
autobotguy is offline  
 
post #14 of 16 (permalink) Old 08-28-2014, 05:43 PM
Member
 
jbarker83's Avatar
 
Join Date: Nov 2013
Location: Norwood
Posts: 97
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Garage
Send a message via AIM to jbarker83
Default

Quote:
Originally Posted by Slorocket View Post
2011 Scion XB Turbo kit

Someone here might have the money for this coveted part(s)... I beleive the same seller has some other things.

ugh.... which I had the money soooo bad.

thats the kit i bought and currently need aq tune for!!!

2014 Scion XB RS 10.0 #909
jbarker83 is offline  
post #15 of 16 (permalink) Old 08-28-2014, 07:19 PM Thread Starter
Senior Member
 
Slorocket's Avatar
 
Join Date: Mar 2012
Location: The western stix of Chitown
Posts: 661
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
(Thread Starter)
Default

So wasnt plug n play as he said huh...

'12 Supra White 5spd

You love me for eveything you hate me for
Slorocket is offline  
post #16 of 16 (permalink) Old 08-30-2014, 08:40 PM
Member
 
jbarker83's Avatar
 
Join Date: Nov 2013
Location: Norwood
Posts: 97
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Garage
Send a message via AIM to jbarker83
Default

Apparently not for autos it plugged in but it won't start I'm so pissed off
jbarker83 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome