ignition problem due to stupidity - Scion XB Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 01-11-2016, 12:16 AM Thread Starter
Junior Member
 
Join Date: Jan 2016
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
(Thread Starter)
Default ignition problem due to stupidity

I replaced my alternator and serpentine belt on 2008xb...I'm no spring chicken and the belt was a *#@%$...so when I got it on I was so jazzed I jumped my xb and had forgotten to attach the electrical wires to my alternator... needless to say, it wont start and would appreciate any input as to what to look at...when I put in a new battery all I get on the dash is oil light and when I turn the key one click and then nothing on subsequent turns of the key...I've checked some fuses but fear it's more than that...any help would be immensely appreciated,
sheepishly yours,
jhoyal
jhoyal is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-11-2016, 02:48 PM
Senior Member
 
Join Date: Jan 2008
Posts: 457
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Default

If the alternator wires were touching metal it is quite possible that you blew the main buss fuse. Depending on your ability you'll need to use a multimeter to test the contacts int he exterior fuse box or tow it to a mechanic.

---------------------------------------------------
Follow me on FB & IG : steelpunkxb
www.Xclusivescions.org
www.nightwerkscustoms.com
www.nightauto.com
Greg S is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome