Scion XB Forum banner
1 - 6 of 6 Posts

· Registered
Joined
·
96 Posts
Discussion Starter · #1 ·
ok so i saw the diy for speaker replacement and was wondering if there are 6.5'' speakers in all 4 doors seeing as the pics from the diy was only the drivers side door. also need some advice about the licence plate right now its on by itself and kinda rattels what should i do so that when the extremly powerful alpine type-r 10'' sub is pointing at it it won't fall off?

Ilive in canada and seeing as how scions arent officialy here yet getting aftremarket parts/adapters,etc.. is .......well lets say ''difficult'' :mad: where would be the best place to get a wiring harness adapter to fit an alpine?
and lastly any approximate time on how much time i'm looking at to replace all speakers (including tweeters) installing new headunit, and wiring for amp ?
 

· Registered
Joined
·
96 Posts
Discussion Starter · #3 ·
doin it myself right tools? unless of unforseeable oddities -yes skills r not a problem im uesed to fabricating my own fitting brackets and installed the system im putting in before so no worries....

but still if any ''special'' tools requiered pls let me know also wiring harness??? and 6.5'' speakers in the rear?
 

· Premium Member
Joined
·
811 Posts
I didn't have the premium Pioneer stereo. There were 5.25" speakers in the rear doors which we replaced with 6.5" with no problems. The notches on the speakers fit the notches on the rear doors, so I guess they were meant to be 6.5". We used the premium front speakers in the rear doors and put a 350w amp back there with them. I wanted a little more volume and "bump" without all the expensive equipment and vibration. It works for me. It's enough to see the gray-haired, fat lady in the "box" with dragons without the shock of subs...
:naughty:
 

· Registered
Joined
·
72 Posts
I just replaced my speakers this weekend. 6.5's in the front and 5.25 in the back. I put a set of 6.5 polks in the front and a set of kicker 6's in the back. The sound is noticeably better but not louder since I didn't install any amps. The rear speakers don't seem to be driven very hard from the head unit.
 

· Registered
Joined
·
96 Posts
Discussion Starter · #6 ·
Thanks for the input and experience got mie 90% done today and 5.25 in the back and 6.5 in the front
swaped 6.5 component in front 6.5 coax in back +300w rms amp powering a 500w rms 10 sub oh and the headunit is gone alpine (the last of the goodones)
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top