Scion XB Forum banner
1 - 6 of 6 Posts

· Registered
Joined
·
59 Posts
Discussion Starter · #1 ·
Hello Guys.


I just wanna post on my recent problems with my xb.
I noticed that as soon as i get the oil changed the car the very next day has 2 quarts missing. My guess now that its either burning or leaking.. I should also point out that before all of these problems happen the car has been fine.


I did a google search on the problem and was surprised that other scion xb owned for the year 2008 have the same problem and is rumored to have a recall for toyota's for this same problem with the same engine. Not scion.

I called scion to make a report of it and made a appointment with my dealer on why this is happening.. I'm not happy..
 

· Registered
Joined
·
846 Posts
My dealer has the "for life " program so I get free oil changes. Before they give me back the xB, the writer checks the oil level them selves to make sure the it is correct. Appearently they've had problems with levels not being upto spec. My '09 has had no problems with oil so far.
 

· Registered
Joined
·
59 Posts
Discussion Starter · #5 ·
Here the deal.. I had the brakes done by a different Mechanic and he noticed it and put in 1 quart.. From then on its running odd and losing power.. There is no oil burnt smell or puddles underneath. I'm taking it in today to see why this is happening.. I have 108k on it and drive the heck out of the car.. i was hoping it to last
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top