Scion XB Forum banner
1 - 7 of 7 Posts

· Registered
Joined
·
325 Posts
Discussion Starter · #1 ·
My car throws a P301 code every once in a while,. when it does i cant gain any kind of speed, wont go over 40 mph, then it'll disappear (code will) then the car would run fine....sorta, if I'm cruising and left off the pedal it feels like i down shifted. (I have an automatic)
Any idea what this could be?
 

· Registered
Joined
·
325 Posts
Discussion Starter · #4 ·
Sorry, I didnt have time to put all the info I needed to. But I changed the Ignition coil, I changed the O2 sensor twice within a couple of days of each other (had a code for that a couple of weeks ago). I cleaned the Mass air flow sensor. I changed all plugs. The problem comes and goes, but the slight rough idle remains, some days its worse then others. with seems worse with the A/C on. when the P0301 code pops up, the traction light blinks on and off, the check engine light comes on also, but then after a couple seconds give and take, it'll go away and the car runs fine, but the rough idling remains and the what seems to be down shifting when I left off the gas and let is coast also remains. what about injectors? could the number one cyl injector be on it's way out? It cant be the head gasket, car doesnt heat up, smoke and it would be acting the way it does.

When this began, it did suck up a little water in the intake a few weeks ago, enough for the car to stop, it took a while but it started up again finally. Even if it was compression issue, it would not come and go like that. all wifes I checked seem to be fine, no vacuum leaks, and least none i can hear or find eh.

So with all this info, any of you might know whats causing this? the gas mileage is really bad also. Mahalo for the help. :cheers:
 

· Registered
Joined
·
37 Posts
Could be a faulty injector. After a nice drive try the following. If it stays bad during idle, I would suggest to remove the spark plug from cylinder 1 and use a flash light to inspect the top of the piston for any fuel. If fuel is present then I'd suspect a leaking injector. Again if the idle is constant, then I would also recommend to remove the connector for injector 1 and see if the idle pattern changes. If it doesnt, then I'd suspect an injector.


Sent from AutoGuide.com Free App
 

· Registered
Joined
·
325 Posts
Discussion Starter · #6 ·
Could be a faulty injector. After a nice drive try the following. If it stays bad during idle, I would suggest to remove the spark plug from cylinder 1 and use a flash light to inspect the top of the piston for any fuel. If fuel is present then I'd suspect a leaking injector. Again if the idle is constant, then I would also recommend to remove the connector for injector 1 and see if the idle pattern changes. If it doesnt, then I'd suspect an injector.


Sent from AutoGuide.com Free App
Great! finally and direction i can t go! Mahalo nui loa bra for the info. I'll get on it right now and see whats going on. :cheers:
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top