Scion XB Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
476 Posts
Discussion Starter · #1 ·
I bought a replacement filter from Wal- Mart, Fram, and it doesn't fit. It was close, but not close enough.

Other than those that use the K&N filter, what brand of throw away filter did you buy and where?

I have 30K now and the original filter doesn't look bad.
 

·
Registered
Joined
·
474 Posts
scion said:
I bought a replacement filter from Wal- Mart, Fram, and it doesn't fit. It was close, but not close enough.

Other than those that use the K&N filter, what brand of throw away filter did you buy and where?

I have 30K now and the original filter doesn't look bad.
Hmmmm, "...close, but not close enough." Prior to installing my CAI I ran with the K&N filter...during installation of the K&N I was beginning to feel like it was also "close, but not close enough"....Problem was solved by using silicon spray to get the K&N to seat correctly allowing the filter cover to latch...you may have the same problem with the WalMart filter.

Brewski
 

·
Registered
Joined
·
476 Posts
Discussion Starter · #3 ·
The angle part of the filter is at a slightly different angle allowing for a gap at one corner of the box. When I held the filters up against each other you could see the angle difference. The filter goes in the box, but won't seal in one of the angle corners.
 

·
Registered
2008 xB
Joined
·
566 Posts
scion said:
Geezer, let me know if it fits, mine might just be a reject.
Fits fine and I find it hard to believe that there would be a fit problem on a mass produced item like this. The diagonal side of the filter fits differently than the other sides, so maybe you didn't have it seated right. You also might have the wrong part number. I'll fish the box out of the trash and double check the number on the filter I bought.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top