Scion XB Forum banner
1 - 20 of 24 Posts

·
Registered
Joined
·
66 Posts
they're still on, and i got this two codes P0037 Oxygen sensor heater control circuit low (Bank 1 sensor 2) and P1604 Startability Malfunction, no idea if is O2 sensor 1 OR 2 or worth both sensors:confused:
 

·
Registered
Joined
·
595 Posts
CEL comes on cause when you remove OEM exhaust manifold you actually remove your catalyst coneverter. To fix that problem you install a CEL eliminator on your OEM s-pipe. All you do is remove your 2nd O2 sensor and then install the CEL eliminator and then put the O2 sensor on the CEL eliminator. This will no cause you to throw the CEL.

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
22 Posts
ok but what if i get the header with the s pipe does the new s pipe have the same hole to put that cel in. sorry to sound dum but just want to get this right and under stand b4 buying it. so when i install it , you have the 02 sensor that you can see from under the hood then do you have another one on the oem s pipe, this is factor still, so when i get the new header and s pipe i install the 02 sensor in the same spots just like stock? or put the 02 sensor in from under the hood and get a cel and put that on the s pipe right.
 

·
Registered
Joined
·
314 Posts
ok but what if i get the header with the s pipe does the new s pipe have the same hole to put that cel in. sorry to sound dum but just want to get this right and under stand b4 buying it. so when i install it , you have the 02 sensor that you can see from under the hood then do you have another one on the oem s pipe, this is factor still, so when i get the new header and s pipe i install the 02 sensor in the same spots just like stock? or put the 02 sensor in from under the hood and get a cel and put that on the s pipe right.
Depends if the aftermarket s-pipe has the cell eliminator the tsudo spipe does have it just unscrew from stock and screw it in the new s pipe. Yes both 02 sensor go back like stock ones do. One for the headers and one for the s-pipe.

Sent from AutoGuide.com Free App
 

·
Premium Member
Joined
·
271 Posts
even if it doesn't have a fitting for the sensor just drill a whole and weld a bung to make it fit... i have a set of custom headers made from a shop here in Aus. when we made the s pipe we just followed the stock one and yeah drilled a hole and welded a bung for the weapon r cel eliminator...
 

·
Premium Member
Joined
·
271 Posts
ok just going to have to really think about it just dont want any issues and lights on

just get a weapon r cel eliminator you will be fine.... or get some anti foulers... seams a simple job... on of the rukus owners out here is running them with no dramas... Im pretty sure he just followed the diy on SL
 

·
Registered
Joined
·
22 Posts
ok so if i get the header and put back both sensors and have lights come on take the one from the s pipe and put this cel adaptor piece in and the sensor back on it will take care of the lights coming on right. sorry to keep asking about this just looking to do it right and the only place i know to get the help and answers is to ask my fellow scion peps about it that know it better then i do or are running this and have had the issues and fixed it and how they did it :)
 

·
Registered
Joined
·
314 Posts
I have a tsudo set up and no lights since install, its been 2 months
 

·
Registered
Joined
·
595 Posts
ok so if i get the header and put back both sensors and have lights come on take the one from the s pipe and put this cel adaptor piece in and the sensor back on it will take care of the lights coming on right. sorry to keep asking about this just looking to do it right and the only place i know to get the help and answers is to ask my fellow scion peps about it that know it better then i do or are running this and have had the issues and fixed it and how they did it :)
you have to get the eliminator no matter what cause as soon as you turn the car on with the new header light will go on so just make sure to get it and install it when you replace the OEM exhaust manifold.

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
22 Posts
ok so where the o2 sensor is under the hood that you see goes one the new one in the same spot and then when you install the s pipe where the second one is you install that piece then the sensor correct.
 
1 - 20 of 24 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top