Scion XB Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
279 Posts
Discussion Starter · #1 ·
Ok so my 08 xb died on me today driving home from school. I hit a lil bit of traffic and than the car died so I try turning it on it came in than died so I tried again it came on and I gave it some gas and it stayed on and I drove home.. Now I didn't have no check engine lights no volt lights both other than the maint req. light that came on then went off and far as I know with that light is it means change my oil.. Now I'm thinking maybe fuel pump or the Mac senser on the cai.. What u guys think?
 

·
Registered
Joined
·
112 Posts
My 09 has been doing the same thing, I start it recently and 1/5 times it stalls and the battery symbol come up. And then as I'm backing out I hit like 300 rpm and I stall or it regulates out. I bought injector cleaner yesterday so we will see. Also I ran Sunoco 89 for the first time.
 

·
Registered
Joined
·
112 Posts
It's so dumb because I thought it was PS, I figured I was workin it because I have less wheel space because I'm lowered. But I can fully turn my wheel both directions and it fine but as soon as I start to roll it drops in rpms and almost stalls and when I came to a stop light today I almost stalled again I droppe to like 250 then it shot back up.
 

·
Registered
Joined
·
22 Posts
Based on what you described it almost sounds like your MAF (Mass Air Flow Sensor) is acting up.

The MAF will detect the presence of air speed within the intake tube. When the MAF becomes dirty, it's unable to give a true reading to the ECU at low idle and will cause poor performance, hesitation and stalling.

Since you said the XB started up after you gave it more gas which in turn opened up the throttle and allowed a larger volume of air to pass over it kinda makes sense.

The MAF is made of palladium and platinum and you need to use MAF cleaner on it. Do not use Throttle Body or Brake Cleaner or you will ruin the sensor. You an pick up the correct cleaner at NAPA or Advanced Auto for about $6.00. I would try that first.
 

·
Registered
Joined
·
279 Posts
Discussion Starter · #8 ·
U know I was thinking that cuz I do have a Trd cai on it but I thought that would throw a check engine light but I'll try that should I just pull it out and clean it or try and spray it up the intake tube
 

·
Registered
Joined
·
22 Posts
U know I was thinking that cuz I do have a Trd cai on it but I thought that would throw a check engine light but I'll try that should I just pull it out and clean it or try and spray it up the intake tube
The check engine light will only light when it detects no voltage or an open reading on the sensor.

Take it out and clean it while it's out of the tube. Just use the spray on it. Don't feel inclined to wipe down the wires or touch them either. That would be bad :)

If you just spray it while it's still mounted in the tube, you're just going to end up wasting the cleaner and flooding the car.

Since you're in there. Double check all of your connections and clamps and make sure everything is tight and sealed. It's possible that you may have a leak somewhere and it's drawing excess air.
 

·
Registered
Joined
·
24 Posts
did u have ur recall done, for the coil packs, u could have this issue, just a thought, and also check ur oil, i had this kinda issue with my last car, if the oil was low it would die down in rpm's. and scott, the xb2 dont have a power steering pump, we have electric power steering.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top