Scion XB Forum banner
1 - 7 of 7 Posts

· Registered
Joined
·
74 Posts
Discussion Starter · #1 ·
So I did installed my Anzos yesterday and I am wondering where to put the little black box that is attached to them. If you just let is dangle you can hear it hitting the inside of the bumper every time you step on the gas or brake. Not sure how or where to secure it to.

Please help.

Thanks!
 

· Registered
Joined
·
254 Posts
One of the sides of boxes has a film that can be peeled off to reveal a super sticky side. I just stuck the black boxes to the inside of the car body, past the tails. Hope this helps.

I had trouble w one of the circular wire plugs not twist-locking all the way. One on each light. I don't think it matters since they're not holding bulbs anymore.
 

· Registered
Joined
·
74 Posts
Discussion Starter · #3 ·
Thanks for the quick response!!!!! I will try this. I saw that one side of the black box was red but did not put two and two together.

Yeah I have 1 that will not twist in...I thought it was in there good but every time I look at it it is unlocked again! Will not having these locked in though allow for moisture to build up inside the tail lights?
 

· Registered
Joined
·
18 Posts
Yeah I wouldn't risk it with the moisture thing - maybe use electrical tape at the least to seal the hole. I also wonder if that contributes to the lights covering fogging over time...

I used the sticky side to hold the box down on mine, but for whatever reason one of them popped off. So I decided to just use liquid nail - just a heads up :)
 

· Registered
Joined
·
74 Posts
Discussion Starter · #5 ·
After working on it some more...with the help of pliers I was able to lock in the one plug that did not want to stay in place before. Bare hands alone was not doing the trick.

I have successfully adhered the black boxes. So far so good.....

Do you think it matters if the wires on the inside of the black foam? I left th foam in place and then started putting everything together and now the wires are on the outside of the foam. but I noticed that on the stock lights the wires were on the inside of the foam. Not sure if that was done so it looks pretty or if there is a valid reason for it?

Thanks for all of your help guys.
 

· Registered
Joined
·
254 Posts
Is the rubber a padding agaisnt the metal of the car for the wires? I put mine inside the rubber, but only because the first was like that....

oh i really don't want to open those back up to twist the locks in.....but i will someday. Thanks for the tip- i was just afraid pliers would snap the plastic or something.

-joe
 

· Registered
Joined
·
74 Posts
Discussion Starter · #7 ·
Yes the rubber is against the metal.....wire stick out from the middle and I do not think they are hitting anything. Everything works fine...so I may leave it the way it is. I do not want to have to take everything apart again either ;)
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top