Scion XB Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
i just installed a system and i think the remote wire shorted out on something :mad: and now my radio is shot, i tryed all the fuses that i know of. but nothing i can find about the radio fuse or my radio is shot :confused:. I need help to find out which fuse powers the radio asap!!! bc i cant drive with no tunes lol
thanks :cheers:
 

·
Registered
Joined
·
559 Posts
Its one of your 10a fuses under your dash. Its a royal pain in the *** to get to them but mine went out once and my fuses LOOKED OK. but i replaced the ones associated with the radio and it worked. In your manual it explains which fuses power each section.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
well i took the radio out and meter the wires and finding out the remote wire is not working but the hot wire is good.. so the gray wire (remote) is shot and i guess imma buy few fuses and replace them all lol but i also put the meter on all of them and it seem just fine idk what to do
 

·
Registered
Joined
·
559 Posts
well i took the radio out and meter the wires and finding out the remote wire is not working but the hot wire is good.. so the gray wire (remote) is shot and i guess imma buy few fuses and replace them all lol but i also put the meter on all of them and it seem just fine idk what to do
your remote wire for the amp? Id suggest changing your remote wire to a different connection and see what happens. Its a good possibility the radio blew its internal fuse and is toast.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
well idk if the radio unit is toast yet, but i know it cant work if the remote wire to the radio doesnt get power the any radio doesnt work.. its all good, i got an appointment with the dealer ship to find the issue ill diff let u know what it was so if it happens to anyone u can fix it ur self lol
 

·
Registered
Joined
·
559 Posts
should try to get them to do it as an inspection so its free until they find something wrong. But all dealerships might be different than the one i work at. Im hoping its a $2 fuse for you like mine was.
 

·
Registered
Joined
·
159 Posts
replace the fuses and go from there. you can take the acc wire and ign wire and go to constant power temp to see if the radio is ok as well.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #15 ·
Alright it was a .5 amp fuse somewhere that was blown they didnt tell me where but the stock unit was toast so, i bought me a new 7inch doubledin dvd unit which looks perfect in this xb but thanks for all the feedback and help
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top