Scion XB Forum banner
1 - 9 of 9 Posts

· Registered
Joined
·
143 Posts
Discussion Starter · #1 ·
Help me please

Alright so I ordered 1157 LED switchback bulbs. I already have the LED Flasher Relay installed on my 2008. When I installed the bulbs and tested them out at home everything is working fine.
Later on that night I was driving around and as I pulled up to my mom's house I went to check out my switchback bulbs they were completely turned off. I tested them out and they weren't working at all.
I turned off my headlights and turned back on... I got only one bulb to turn on White the other was off. I checked the turn signals (amber) and it wouldn't turn on.

So I'm lost on whats going on... I have the LED Flasher Relay which I'm not getting the hyper flash. But now my bulbs aren't working. *side note, I already have replaced the bulbs once :eek:
 

· Registered
Joined
·
143 Posts
Discussion Starter · #2 ·
I'm wondering if I get resistors would I connect both positive wires together to one side of the resistor and the other side of the resistor to the ground??
 

· Registered
Joined
·
979 Posts
I don't think I'd add resistors unless you switch back to your original flasher relay. I think the first thing I'd do is put your old incandescent bulbs back in to see if they work. That would tell you if the problem is in the bulbs or somewhere in the car. Since the one light came on after not working, I would lean towards a bad connection somewhere. Make sure the bulbs are twisted all the way in. Take them out and look at the contacts on the bulb and inside the socket for corrosion.
 

· Registered
Joined
·
143 Posts
Discussion Starter · #4 ·
I checked the bulbs and still getting the same thing... one side is off and the other is just showing White light only... these switchbacks are from ddm tuning too shipped from china. I'm going to try a different company and see if I get the same results.

I put in the old incandescent bulbs back in and everything works perfect.
 

· Registered
Joined
·
979 Posts
Did you bench-test the switchbacks?

I bought mine used from a member here and they work great. I think they came from vled's.
 

· Registered
Joined
·
143 Posts
Discussion Starter · #6 ·
Did you bench-test the switchbacks?

I bought mine used from a member here and they work great. I think they came from vled's.
Sorry I'm not aware of the bench-test? what is that?

Tell you the truth I may go with vled or ledmod for the switchback and get my money back from ddmtuning
 

· Registered
Joined
·
979 Posts
Oh, sorry. Bench-test literally means test it on a workbench. Take them out of the car and put a battery on them to see if they light when all the switches and wires are taken out of the situation. Since your incandescent bulb work though it can't hurt to return them if you can get a refund.
 

· Registered
Joined
·
143 Posts
Discussion Starter · #9 ·
Oh, sorry. Bench-test literally means test it on a workbench. Take them out of the car and put a battery on them to see if they light when all the switches and wires are taken out of the situation. Since your incandescent bulb work though it can't hurt to return them if you can get a refund.
Yeah I'm going to try to get my refund and get them at ledmod.com i'm on a mission to fulfill this project haha
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top