Scion XB Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
141 Posts
Discussion Starter · #1 ·
If you bought the led tail lights from toyota with in the last year you may want to check the brake lights! I recently had to replace both tasil lights as LED circuit boards seem to have been fried. I ma not alone on this one either Sparks said they seem to be shipping out a few also lately.We also ahd to return old ones on which sparks paid for shipping and provided labels adn return boxes also. This should be a warranty coverage item as mine were!
 

·
Registered
Joined
·
289 Posts
:eek:hno: Were they fried & not working? Or working but fried? I have those LED tail lights installed @ the dealership: they're working perfectly so if I check & see they look like they're frying I'd definitely go after warranty...
 

·
Registered
Joined
·
474 Posts
Just checked mine. Still working great after eight months + in service. Where there any after market trailer lighting harnesses installed?

Brewski
08 xB
 

·
Registered
Joined
·
141 Posts
Discussion Starter · #4 ·
not on mine! Just replaced tail lights
 

·
Registered
Joined
·
7 Posts
Ordered optional TYC led taillights. Both have failed at different times - brakelights only. One at about 7K miles and other at about 9.5K miles. Each have been replaced under warranty. I really like the look of these units and am disappointed at their reliability so far. Just rolled-over to 10K miles.
 

·
Registered
Joined
·
474 Posts
dickmanne said:
Ordered optional TYC led taillights. Both have failed at different times - brakelights only. One at about 7K miles and other at about 9.5K miles. Each have been replaced under warranty. I really like the look of these units and am disappointed at their reliability so far. Just rolled-over to 10K miles.
Hmmm, I installed the TYC taillights back in March and so far no problems...anyone else having a problem with these lights? (I also really like the look of these lights.)

Brewski
 

·
Registered
Joined
·
474 Posts
xseveredveganx said:
My passenger's side went out. One of the LED's around one of the rings went out, too. Kinda irks me...

:mad:
That is a bummer! I'm keeping an eye on mine...and I would hate to have to replace them with the original lights.

Brewski
 

·
Registered
Joined
·
528 Posts
For real! The OEM ones are okay, the Anzo ones are alright, but I still like the TYC's. I want to get them tinted, but I'm kind of waiting to see if these do the same as my other ones. I hate to spend $300+ on something that's only going to work for a year.
If there were more options out there, I would've sold these when I got the second set. But there's not much yet. Oh well.
 

·
Registered
Joined
·
12 Posts
Mine lasted a few days short of a year, under warranty, passenger side brake light stopped working, everything else was fine on it. Totally sucks. I havent decided if i should put my new set on, cause if it/they burn out again it wont be under warranty!
 

·
Registered
Joined
·
1 Posts
Wow, I'm seriously glad to know this is a widespread problem. I've had issues since I took delivery of my 09 xB last November. Both lights had bad clusters... some of the LED's in the brake cluster were brighter or dimmer than others.

Unfortunately my dealership gave me a serious runaround, saying that they still technically work so they aren't a warranty-covered repair. After a ton of arguing, they replaced just ONE of the lights. The new one is perfect, all the LED's have uniform brightness. Unfortunately, the second one stopped lighting entirely a couple of days ago. I'm going to my dealership today for my 20k service and they damn well better order a light for me.

I do have a question if anyone else ends up reading this thread.. is it possible to replace the clear plastic covers of the TYC lights? The light the dealership replaced a few months back functions perfectly but the plastic has a small hole in it, courtesy of my girlfriend's idiot brother. The replacement cost of the light is a hell of a lot more than I want to pay because of some broken plastic when the light works perfectly otherwise.
 

·
Registered
Joined
·
474 Posts
As of 2 weeks ago my TYC LED taillights were still going strong (for about 18 months)...I'll check when I get the xB back from the Dealer with the new lower block installed due to the hydro-lock.

Brewski
 

·
Registered
Joined
·
94 Posts
My driver's side TYC amber brake matrix burned out except for a few bulbs. No brake light in this city is asking for a ticket. :yucky: Luckily I still had the original tail lights and they were easy to put back in (still kicking myself for paying the dealership to do it the first time). It hasn't been a full year from what I remember, BUT... I bought them from someone else and had the dealer install them. No receipt, can't attempt to get them replaced, and it sounds like a lot of people have issues with getting them replaced anyway. Definitely writing a letter of complaint, since this sounds like an on going problem.
 

·
Registered
Joined
·
474 Posts
Brewski said:
As of 2 weeks ago my TYC LED taillights were still going strong (for about 18 months)...I'll check when I get the xB back from the Dealer with the new lower block installed due to the hydro-lock.

Brewski
So far so good with my TYC LED taillights...still going strong, now close to 24 months.

Brewski
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top