Scion XB Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello all,
I have a conundrum...I have a 2006 xB. The brake lights/tail running lights went out on both the passenger and driver side but the third brake light on the hatchback door still worked fine. I thought it might be a fuse since both of the lights were out. I checked for continuity and the fuses all tested fine. Then I thought maybe both bulbs went out at the same time...weird, but I thought maybe, so I went and got new bulbs and changed them. Nothing happened. So I left it that way for a little while...I searched different places trying to find an answer. I can't find anything about this issue that isn't related to the fuse or the brake light switch. Both seem to be functional in my xB. So I took the light sockets out and inspected them and tried to make sure they weren't cracked or corroded. Clean as a whistle and look brand new...no cracks, no corrosion. I started to play musical light sockets and bulbs and after switching things around a few times the brake lights on both sides started to work but the running tail light on the driver side is not coming on with the headlights still. The same bulb works just fine when I press on the brake pedal but it doesn't illuminate as the running light, only lights up when I press the brake pedal. I am pleased that the brake lights work again, but very confused as to why the running light doesn't come on on the driver side. Does anyone have any suggestions? Thanks in advance.
 
1 - 1 of 1 Posts
Top