Scion XB Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #1 ·
Just got a 2010 h/u I bought off of a member on the site. While swapping out my standard h/u on a 09 for the 2010 unit I noticed my ipod won't play. I push the button and nothing happens. Did I miss something during the install?
 

·
Registered
Joined
·
286 Posts
When you push "the button" does it show "ipod" on the screen? If not, you have to push it again. If that doesn't work then there's a connection problem where it's not recongnizing your ipod.
 

·
Registered
Joined
·
1,069 Posts
The '10 HU's use a USB/Aux input on the console instead of the iPod/Aux input on the '08s and '09s. I have seen those for sale before, so you might be able to pick up the '10 USB/Aux port somewhere.
 

·
Premium Member
Joined
·
811 Posts
I have a 2010 and there is a USB port, but also an AUX plug. The 2010 HU might not match up with the plugs. I used the AUX for my Zune until I decided that the quality of sound was better with a flash drive in the USB.
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #6 ·
i was under the impression that it would just be plug and play, and everything would work just fine. I read somewhere else that they have used a 1K OHM Resistor on the back of the headunit to get the ipod to work. :cry: I just want to get this fixed ASAP so i can move on to my next mod :cry: starting to pull my little hairs out :help:
 

·
Registered
Joined
·
286 Posts
What type of connection/cable are you using to link to the h/u. The 2010 uses either a USB or aux (rca type) connection.
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #8 ·
im using the cord that came with my 09 xb. its what plugs directly into the ipod slot. the 09's dont have a usb port. they only have a big squared plug that plugs into the ipod and a aux port that i dont have and cords to because they didnt come with the car.
 

·
Registered
Joined
·
286 Posts
I don't think the 2010 h/u will work with that "square" plug because they are made to work with either the aux or usb. Did you say that it wouldn't work with the aux cable/connection?
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #10 ·
Yeah, I tried using the AUX port but it didn't work either. Now, I think I'm stuck with a sweet looking headunit with no ipod compatibility with my xb. I'm still holding out hope that there is a way to modify the 2010 headunit to work with my 09 and let me play my ipod.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top