Scion XB Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello everyone New Member here.
I am looking for any help I can get. I own a 2009 XB and about 2 weeks ago I lost the air flow from my vents. When I move the air dial no speeds work. When I select the A/C button it does not light up and start the compressor. I have replaced the Blower and Blower Resistor but now am not sure where to look. It is starting to get hot here and really miss my air. Any help would be very appreciated. Thanks in Advance.
 

·
Registered
Joined
·
422 Posts
Be like me, drive with windows down :). But seriously ummm where did you get the car from? Could the dealership look at it? I'm sure you thought of all those options already.
 

·
Registered
Joined
·
782 Posts
Hello everyone New Member here.
I am looking for any help I can get. I own a 2009 XB and about 2 weeks ago I lost the air flow from my vents. When I move the air dial no speeds work. When I select the A/C button it does not light up and start the compressor. I have replaced the Blower and Blower Resistor but now am not sure where to look. It is starting to get hot here and really miss my air. Any help would be very appreciated. Thanks in Advance.
You should have fresh air flow through the dash vents when the left HVAC control is set to a non-defrost position, its center lamp is off, and you are moving at a reasonable speed -- not necessary to turn on the fan or A/C. Separately, if the fan or A/C doesn't work, then first guess is a fuse.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top