Scion XB Forum banner
1 - 16 of 16 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I'm not sure if this is a repost. I just joined the forum today. But i was wondering, I picked up my 08 Xb back in Nov. 2007. I'm in Wisconsin so traction is in issue. I had no problems in the 2007 winter, but lately I've been seeing my check engine light and my VSC OFF light go on and off. The car is going to the shop this tuesday, but I was wondering if anyone else has experience this problem.
 

· Registered
2008 xB
Joined
·
568 Posts
I had a problem recently and the "check engine" light came on along with the "VSC" light. The dealer told me that the vehicle stability control is automatically disabled when the "check engine" light comes on, so the "VSC" light comes on as well.

Based on that, I'd guess that you have a "check engine" problem, not a stability control problem.
 

· Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
There's 19000 miles on the car. i've notice the problem since the last couple snow storms here. it was after running through snow that would scrape the bottm of my Xb. Which would cause build up under the car. when it warms up and washes away, the lights go away. I've been told it could be tranny problems. i know my car slips gears when the lights are on, cause the cars an automatic. Went to the dealer today, they didnt find anything. not sure what to do.
 

· Registered
2008 xB
Joined
·
568 Posts
Are you sure it's not just the normal feeling of the VSC kicking in when driving in snow? From the Toyota website...

"Two things happen when Vehicle Stability Control detects this loss of traction. First, engine output is reduced. Then, brake-force is applied to individual wheels as needed. This helps correct the wheel slip and helps prevent skidding."
 

· Registered
Joined
·
2 Posts
i have the same same problem it started this morning i started my car and the engine light is on and the vsc light just keeps flashing i took it to get get checked they also told me everyting is fine i dont fell the car power or anything else diffrent. i looked through the manual to find how to reset but i did not find it.my car is an xb 2008 and it has 27,000 miles on it.can u help me out
 

· Registered
Joined
·
88 Posts
I'll keep saying it because it has seemed to be a problem with a few people i know with 2.4's including myself, the ignition coils crap out. I had mine replaced at 12,000 miles. The car just up and died on me one day with no previous symptoms
 

· Registered
Joined
·
167 Posts
I spaced it and left my fuel cap off for a day or so. Now my Check engine light is on, the VSC light flashes, and some other light (car with squiggy tracks) stays on constant. I called the dealer and a service guy said it would go off in a week or two if it was the gas cap. He said if the car ran fine, then I shouldn't worry.

Anyone know how to reset the lights w/o having to need a special tool? I've been wanting to buy a Scangauge, which is suppose to be able to reset error codes, but it isn't in the budget right now.
 

· Registered
Joined
·
294 Posts
You can disconnect the battery and it will do hard fault reset.
 

· Royal Floor Sweeper
Joined
·
4,338 Posts
If you do that, leave it disconnected for a while, so any backups will decharge. In our fridges, this might not be that relevant, but I'm not sure. In some other computer controlled vehicles, there are mini batteries for computers so that any electrical failures allow safe exit w/o everything shutting off suddenly.

(Of course, that may be old-tech, as it's based on experience w/ older vehicles. Newer ECUs may be different.)
 

· Registered
Joined
·
167 Posts
Thanks for the replies, ironically, the lights all went off later that day (after being on for about 3 days). Always nice when the problem fixes itself.
 

· Registered
Joined
·
1 Posts
I have had the same problem on three different occasions in the last week. VSC and check engine light both go on. Dealer said to tighten gas cap, then turn the car on and off three to four times. This procedure worked on two prior occasions, the lights went off and car worked fine. It happened again today, tried the reset but lights are still on and car not running well.. Worse, the vehicle had increased acceleration, from about 62mph to 67 mph as I drove home. Waiting for dealer to fix this problem. Anyone else experiencing this additional Toyota problem?
 

· Registered
Joined
·
1 Posts
Having the same problem.....The VSC/ABS and Trac Lights flash, has been on and off since purchase in July 2008. Just picked up my xB from Toyota Dealer (South Florida) on 02/18/10. They replaced an engine harness and brake light switch. All was well till I started my xB this morning.....Lights are back on. Going to call them back and take it back in. Anyone else have the same problems and had it fixed?....... :(
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top