Scion XB Forum banner
1 - 2 of 2 Posts

· Registered
Joined
·
979 Posts
Discussion Starter · #1 ·
Ok, so I installed the new rear hub assembly yesterday. I was a little worried, because in everything I've read people have complained about how hard it was to get the old one off. I stumbled upon a little trick that made it a breeze. Maybe it is old news for experienced mechanics, but here it is.

Here is the old hub. Notice the 3 holes to access the 4 bolts holding the hub to the car. Notice also that one is bigger than the others - that's important later.


Here you can see one of the bolts partially unscrewed. They were easy to access by turning the hub until one of the holes lines up for your socket to reach the bolt. I didn't even have to fight much to loosen them.
]

The exception was when I put the socket through the larger hole once and before the bolt was all the way out, it got tight and I thought it was rusted on. Then I noticed that the larger hole is further from the center and the shoulder of the socket was jammed against the hub DOH. I screwed it back in a few turns and rotated the hub to use the smaller holes and easily removed all four bolts.


Because of the dust shield, you can only get a hammer on one side of the hub. I smacked it for a while and it never budged. I tried to get a pry bar behind it with no success. Here is the trick I figured out. I remembered the socket becoming jammed behind the large hole in the hub. I put a bolt in the lower left hole and rotated the hub to like it up with the large hole. Using a breaker bar, I backed the bolt out again until the socket was jammed against the hub as tight as I could get it. Then I took a hammer and hit the opposite (right) side. Two taps and the hub popped right off!


The trickiest part was disconnecting the ABS sensor wire. The clip is on the bottom. I had to pull the hub away from the car until I could see the wire connector. Then I rotated the dust shield which turned the back part of the hub until I could see the connector latch. A small flat screwdriver easily popped the wire connector off of the hub. Sorry, no picture of that.

Here is a picture with the hub removed in case you're curious. Note the use of a wire to hold the caliper up to keep from straining the flex line.



From here it took 15 minutes to wire-brush the hole, install the new hub, reinstall the caliper/rotor, and go for a test drive.

If I were to do this again, I would buy a new dust shield. This one was rusted and even had a few pinholes in it. I cleaned it up with a wire brush and degreaser then spray painted it black again. It looks rough up close, but you can't really see it anyway.
 

· Registered
Joined
·
979 Posts
Discussion Starter · #4 ·
I am wondering, how much the dealer would charge to do this?
Just the part was $440 from Toyota. I bought a name brand hub (Raybestos) from RockAuto.com for about $120.

Total time involved was about 1 to 1-1/2 hours. That is from jacking it up to having the tools put away. That is not counting the time I quit to go to the grocery store and make/eat supper while the paint dried on the dust shield.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top