Scion XB Forum banner
1 - 10 of 10 Posts

· Registered
Joined
·
1,207 Posts
Re: Resetting Engine Maintenence Required light. -revised

set the trip meter to 'A' and turn ignition off - then hold down trip meter button with ignition off and turn key to on while holding the button down for ~5 seconds - the light will flash a few times and then turn off.

it is then reset :yes:
 

· Royal Floor Sweeper
Joined
·
4,338 Posts
Re: Resetting Engine Maintenence Required light.

Thanks.
That will be helpful, as I plan to change my own oil after the 2 "freebie" Scion/Toyota changes.
 

· Registered
Joined
·
101 Posts
Re: Resetting Engine Maintenence Required light.

Page 99 in the owners manual...I can never remember how to do it!!
 

· Royal Floor Sweeper
Joined
·
4,338 Posts
Re: Resetting Engine Maintenence Required light.

TunerChick said:
Page 99 in the owners manual...I can never remember how to do it!!
Oh . . .
I guess I need to actually LOOK at that more often . . .
I've been too busy DRIVING to read that until I have a need to or time to blow.
 

· Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
Re: Resetting Engine Maintenence Required light.

pman said:
Page 99 in the owners manual...I can never remember how to do it!!
Well dang, I looked and looked for it but couldn't find it. So I concluded it was just one of those details that the dealers would prefer that they did. Thanks.

And thanks to yanges for telling me the method. I did it last night. I first just tried (assuming wrong) to push the odometer button during the process and that didn't work. I reread the description where it said "Trip" button. So I pushed the odometer button once to change it to "Trip" mileage, did the process and bingo.
 

· Registered
Joined
·
1,207 Posts
Re: Resetting Engine Maintenence Required light.

pman said:
pman said:
Page 99 in the owners manual...I can never remember how to do it!!
Well dang, I looked and looked for it but couldn't find it. So I concluded it was just one of those details that the dealers would prefer that they did. Thanks.

And thanks to yanges for telling me the method. I did it last night. I first just tried (assuming wrong) to push the odometer button during the process and that didn't work. I reread the description where it said "Trip" button. So I pushed the odometer button once to change it to "Trip" mileage, did the process and bingo.
glad to help pman! and Welcome to NSxB!!
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top