Scion XB Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I bought a new 2012 Scion Xb about 6 months ago and it had a 3 second hesitation when I would step on the gas pedal. Unfortunately, it would only happen randomly. I recorded each time it would hesitate and after 2 months I brought the car back to the dealer and the dealer consulted with Toyota and they replaced all the injectors and spark plugs (dealer had the car three weeks.) After these changes I drove the car another month, but it did not correct the problem. The problem occurs when I start off from a stopped position and turn to the right or left. It occurs randomly and at different times during the day. It may skip a few days- but it doesn't go away.

The dealer gave me a second new 2012 XB and I have driven this car about 2000 miles. Believe it or not -this new car is exhibiting the same symptoms as the first car. I tried using high test gas - it didn't resolve the problem. I love this car - but I cannot live with this dangerous hesitation problem. It is like the computer has a virus and randomly creates this hesitation problem. I am sure the dealer thinks I am the problem, since, it doesn't happen when his mechanic tries to duplicate the problem.

Any suggestions?? This is a living nightmare!
 

·
Registered
Joined
·
58 Posts
Maybe silly but have you tried turning off the traction control?

My 12 seems to engage it when turning from a stop quite often (gonna get me killed) and no lighrs come on showing its engaged. If I turn it off, no more hesitation into on coming traffic.

For a longer test you might see if there us a fuse to pull as pushing the button to turn it off is only temporary.

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
661 Posts
Thats my thought too. The traction control button, hold it for a few seconds until 2 lights come on on the dash. C if that helps. There will be no computer interference with startin off. Only thing is. Youll need to do this every time you start the car.

I have noticed this too. Its just the computer tcs crap. And. Its the same in a 5 speed. I don't care for it at all. But its a standard in most newer cars. Ours is just stupid sensitive.

Hope this helps
 

·
Registered
Joined
·
601 Posts
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top