Scion XB Forum banner
1 - 9 of 9 Posts

· Registered
Joined
·
185 Posts
Discussion Starter · #1 ·
I bought my 2012 xb used. And I can't seem to get the usb/ipod connection to work. It didn't come with an interface cable, so I've just been trying to use my normal iPod cord. Should the normal iPod cord work or do I need the special cable? And I also tried plugging a normal USB drive in and still nothing. Will it play flash drives? Nothing happens when I plug either item in. When I wired my subs up I realized the previous owner had an aftermarket headunit in because there's a second wiring harness behind my headunit so I don't know if that has anything to do with why it isn't working. But any help, tips, tricks, and answers are greatly appreciated!
 

· Registered
Joined
·
164 Posts
If your just using a normal AUX cable you should be able to listen to music via an iPod, phone, etc. You just have to control your music through the phone. On a previous head unit even though I had hooked up AUX cables they weren't turned on in the head unit settings. You may have to go through your menus and see if there is an option to turn on the AUX port, if there is make sure it's on. If it still doesn't work you may have to trace the wire to make sure that it is actually plugged in right. I'm pretty sure the only way you can actually control a music player via the head unit or controls is if you use the USB cable. The AUX will only transmit sound, the USB is a data cable and understands more.

I hate extra wires from old jobs in my dash. I would get all the wires you are supposed to have or need and remove any old harnesses. They just take up space and make it really confusing to work with if you ever have to troubleshoot anything. I just got done tearing a bunch of iffy aftermarket light wiring out of my car.
 

· Registered
Joined
·
185 Posts
Discussion Starter · #3 ·
the aux works fine. I understand how those work. The issue is the usb. It doesn't read anything. Do I need a special iPod cable for the USB port? Or should a normal iPod cord work?
 

· Registered
Joined
·
164 Posts
A normal iPod cord should work. It's the same one you use to sync right? This may sound stupid but is the cord in good working order or have a short anywhere? If there isn't anything in the menus, and the cord is in good shape I would check back around to the back of the unit and make sure everything is plugged in properly. If there was an aftermarket head unit that was removed before you bought the car the previous owner may have just plugged in what fit and as long as sound played figured it was good.

Failing all of that do you have a specific head unit installed right now or just a stock one? There may be a user manual online somewhere that will help determine what should happen if a music player is recognized. I don't have a stock head unit in mine but I have seen it in other threads that is is supposed to have "iPod Connected" or something pop up when it recognizes it.
 

· Registered
Joined
·
185 Posts
Discussion Starter · #5 ·
isk1tz, my head unit is a stock pioneer one. But when I pulled the head unit out to wire up my subs I realized there was another wiring harness back there. This is not normal right? So I assume the previous owner had a different head unit. My cord is good and yes its the cord I use to sync. I tried 2 different ones. When I push the usb/ipod button on my headunit nothing happens. But the aux works fine.
 

· Registered
Joined
·
164 Posts
The only other suggestion I would have is to pull the head unit out and make sure everything is hooked up properly. Verify the other harness isn't supposed to be there for anything stock and remove it entirely. If it is stock it may be a generic harness scion installs so they can hook up any optional head units later that may use extra cables like touchscreen or something.

Short of it just not being plugged in the back and assuming the port is turned on via the head unit which if its stock i imagine it should be I'm all out of ideas. Sorry.
 

· Registered
Joined
·
185 Posts
Discussion Starter · #7 ·
well i found a pic of the back of a different scion headunit and found out what the usb plug in on the back of the head unit looks like and mine was unplugged! so now it reads my ipod! but one problem leads to the next. now it says i need to update my ipod! lol. but its an old one so idk if it will even work :/
 

· Registered
Joined
·
185 Posts
Discussion Starter · #8 ·
well to finish this thread off... My iPod is up to date but still isn't new enough to work. So I guess I'll be upgrading ipods. But at least the USB port works now!
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top