Scion XB Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have an 08 XB with close to 66,000 miles. Today the Brake, ABS, VSC and traction control lights all came on. The car runs and handles fine and brakes are fine. Any one had something like this happen before or any ideas what the problem could be???
 

·
Registered
Joined
·
783 Posts
Mine did the same thing, but I only have 25,000 on mine. I haven't figured out how to turn them off, I've driven a good 5000 miles with them on. If you figure out how to get them off, please tell me, they're very annoying.
 

·
Registered
Joined
·
93 Posts
It may be a fuse, it may be a problem with one of the ABS sensors, it may be a computer problem, it might be a short. If not a fuse, you need to go to dealer (or MFR Rep--see your manual) and see if there is a problem with many. If it is a short, you could end up with a fire. If a problem with ABS, you could find out they don't work as they should when really needed. Also to consider...My son had a Hyundai Tiburon which he and his back yard mechanic friends did a lot of things to, especially sound and electrical...then he had all sorts of problems. He swore the car was a piece of crap and Hyundai told him all the mods he did were the cause of his problems and they refused to work on it until he put back to OEM. I had an identical year Hyunda, no unqualified work, just sold with 132K miles and no problems. Just something to consider....
 

·
Registered
Joined
·
240 Posts
finallygotit said:
Hi,

Had the same issue go to brake/vsc problem in scion performance the fix requires an obd2 reader.
Can OBD2 reader these warnings? I always thought that it can only read engine trouble codes.
 

·
Registered
Joined
·
1 Posts
same problem here 2008 XB, 28.8K mikes BRAKE, ABS, VSC track lights came on after the car was parked. Drove the car a couple of miles with the lights on, let it sit for a few hours, starting it up again the lights were on, drove about a mile the lights went off, then came back on.

Same thing this morning lights were on drove about a mile they went off then came back on after another mile or so. Any help would be appreciated, the car seems to drive fine, the brakes work, I'll check the gas cap.

thanks
 

·
Registered
Joined
·
93 Posts
print all these replies and take it to the dealer. If they won't fix, talk to Scion and get them involved. If still no help go to the consumers advocacy group.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top